Amazon Alexa


#81

Sorry just HG (v BE-1.1.15) and HGEchoBridge (v1.0.21).
On a Ubuntu box.
IanR


#82

For anyone who is interested this program is working fine on Gene’s 1.2 v34 version as well.


#83

You mean Bounz Version ? Because Gene’s version is R526.
Yes I am interesting to make HGEchoBridge to work with latest Bounz’s version.
Actually I am using HAbridge last version between HG and Amazon Echo Soft french version 628538220. I can say Alexa to not use external Philips server hue.


#84

No I’m referring to Genes version here https://github.com/genielabs/HomeGenie/releases but it does work with Bounz version too.


#85

I am interresting that HGEchoBridge works fine with Gene’s version. For me it doesn’t work with latest Bounz version also, Alexa did not discover anything.
For the moment I am using HABridge latest version between Alexa and HG and that works fine and rapidely, no long time for action as with Philips Hue world server (For Hue light only).
With HA bridge I can map any On/Dim/Off system control by HG as Heat electrical system ZWave Light and Switch with local HTTP/Api. No Need to expose HG to Internet (As with IFTTT with long response delay). And I can control all of that from my smartphone Outside with Alexa App.

Dani


#86

The best thing to do is try it. You’ll need to disable the external HA Bridge server and UPnP in HG and follow the instructions for EchoBridge installation as outlined by Bounz.


#87

That’s strange. I use my own fork and everything works.
May it be related to the problem with Echo 2nd gen?


#88

Hello
there seams to be problems with everything except get 1 and 2 needing a “link button” Button to be pressed on the bridge before the first discovery.
I cant find this button in the HG version of the ha-bridge.
Also reported on “https://github.com/bwssytems/ha-bridge/issues/1022” the ha-bridge forum as well as needing the “link button” to be pressed is that the gen 3 only uses port 80.

I tried with a gen 2 dot and it found my lights and switches first time.
With the gen 2 on the network all Alexa devises eg echo and the Alexa on my phone, could contrail the lights.
As the dot was borrowed as soon as I removed it from my network (to return it) all the devises (lights)disappeared from Alexa. So no light contrail.
Also it looks like the gen 2 has been taken off sale.

IanR


#89

Hello
Also when I got it working with a gen 2 dot I was using:
HG = v BE-1.1.15 (Bounz version )
HGEchoBridge = v1.0.21.

IanR


#90

That’s the problem with building an Emulator. As soon as a new generation device is released they change the discovery protocol. Part of their marketing strategy with their device producing partners to force you into buying the hardware.


#91

There are changes to the new hardware but the counter measure is all ready in the master program.
Unfortunately it looks like that its missing from the HG fork. unless some can tell me where the “link button” is or a way to get to the web page from the original HA-bridge on the HG version?.
IanR


#92

Have you looked in the Startup Code of the EchoBridge program


#93

I am using HG with the HGEcho bridge and a cm11a interface. HG dims a device from a GUI widget just fine. I can also dim the device from a browser with:

http://192.168.1.8:8080/api/HomeAutomation.X10/B16/Control.Level/50

Voice Commands for On/Off work just fine.

However voice commands for dimming do not work. These are the ones I have tried:

“Alexa, desk Lamp Control level 50”
“Alexa, desk Lamp Dim level 50”
"Alexa, desk Lamp Dim 50 "
“Alexa, desk Lamp Dim 50 %”
“Alexa, desk Lamp 50”
“Alexa, desk Lamp level 50”

It appears that the HGEB does not send out the command that works although the GUI does. How can I fix that?
Thanks!


#94

Hi @alzy,
Just created a pull request to make it possible to dim lights with HGEchoBridge (https://github.com/davidwallis3101/HomegenieEchoBridge/pull/2).
After it is being merged you will be able to download and install a new version of HGEchoBridge.


#95

@Bounz the EchoBridge I have installed is already dimming with my Alexa device. The problem here is the difference between the Euro and the US device. I’m using a Euro Alexa device and the OP is using a US device. Also it now appears that depending on what generation of Alexa device you own certain commands do not appear to work in it.

A simple command like Alexa main light 50 will dim the main light 50% so dimming is working on my device.

Maybe David could check what I reported before digging any further into the code.


#96

My echo dot device is made for the us market. I have both gen 2 and gen 3. Both have the exact same issue. Dim does not work for me. Please dig into the code for us US users! Let me know what you decide from here.

Thanks


#97

Hg version requires a dot gen 2 in the network then all echo units will work including the pad app, throw the dot gen 2.
I also had no dimming with the HG version. and with out a gen 2 dot (only have gen 3 and a echo both EU versions) I can’t connect to HG version,
Also it looks like form the forums anything apart from dot gen 1 and 2 require the include button and to be on port 80. (this setup works for my echo).
I have now installed in to a separate pi the original Alexa ha-bridge, this works well I have on, off and dim. (and the possibility of custom commands to run HG programs not just lights) with next to no delay.
The only thing about the original version is that you have to add every item yourself, its not hard but time consuming.
IanR


#98

I don’t know how this could be possible, because HgEchoBridge doesn’t have a link to API to dim lights in HG (only to turn them on and off, take a look at the code: https://github.com/davidwallis3101/HomegenieEchoBridge/blob/master/MIG-Interface/HgHelper.cs#L64). And this doesn’t depend on the Echo generation or US/EU version.

PR I opened adds the ability to send /Control.Level command to modules in HG.

I assume that the solution with installing HA-Bridge provided by @IanR requires to enter all HG device’s endpoints manually.


#99

@Bounz
Hello

I assume that the solution with installing HA-Bridge provided by @IanR requires to enter all HG device’s endpoints manually.

Unfortunately, yes, as I say you have to add all connection to all light, but that’s not hard. One command for on, one command for off and one command for dim, it just tacked time (depending on the size of your build).

IanR


#100

Maybe @David_Wallis could test to see if his code was working with an Alexa device and the Dim function.

I’d imagine the differences in regional versions and generational differences with the Alexa devices will cause headaches trying to create a one size fits all solution to this issue.