Amazon Alexa


@Bounz followed your link to download EchoBridge zip. Installed it and in the drop down configuration the only option box available IPAddress which defaults to not used.

Where’s the option to change port


The port change is in EchoBridge under the IP address.

Yes I have changed the IP and the port number to that used by HG e.g. and 8080
The server that HG is on has another program that serves UPnP will this affect the bridge/Alexa?


@IanR a little confusing for some setting a port number in a box with a title IPAddress. What version of HG are you using. There’s Bounz fork and Genes latest version which now includes an UPnP library which may cause problems with EchoBridge.

@Bounz would it be possible to update the EchoBridge MIG 1.2 version to reflect that it’s actually the port number that can be changed and not the IPAddress.


@IanR AFAIK there should be no problem with other UPnP servers/programs.

@Petediscrete I can’t check it right now, but as I remember there should be two inputs (one for IP address and other for port number) with correlated titles. I will check this as soon as I’ll be at home.


Sorry for confutation there are two boxes one IP and bellow that Port.
see pic

HG BE = 1.1.15
Bridge = from link above


@IanR downloaded EchoBridge as per Bounz link. In the configuration section drop down box there’s only one option IPAddress to select. There’s no option to configure Port.

@Bounz any idea why the option to select port is missing on the EchoBridge MIG. I downloaded the latest version as per your link


Yes, I have an idea)

  1. Disable EchoBridge interface in UI
  2. Restart HG service
  3. Make sure that EchoBridge is still disabled
  4. Repeat interface installation procedure: upload zip file and install it in UI


Tried that. It made no difference. You made a change to give an option to set a port for HG. What version did you commit that change too.


It’s there in the last release of EchoBridge, available at GitHub. You can verify this by extracting archive somewhere and looking at configlet.html file: there will be input for the port number.

If it’s possible - you can PM me logs of your HG after installation of EchoBridge interface, maybe there will be something useful.


Tried this download link 404 error

Has David changed something I wonder


David hasn’t changed anything but that’s not the correct link… go to the release tab.


The link I used was

I have tried the reinstallations as @Bounz instructions but still no devises found by Alexa.
Are there any particular programs that need to be on. I have all programs disabled.



Found this in the log is it normal?


2019-01-10 19:42:09.3425 Debug Enabling Interface HomeAutomation.EchoBridge
2019-01-10 19:42:09.3442 Info Starting HGEchoBrige Version
System.NullReferenceException: Object reference not set to an instance of an object
at MIG.Interfaces.HomeAutomation.EchoBridge.Connect () 0x420ae000 + 0x0017f in filename unknown:0
at MIG.MigService.EnableInterface (System.String domain) 0x41ee6ce0 + 0x00097 in filename unknown:0
at MIG.MigService.Gateway_PreProcessRequest (System.Object sender, MIG.ProcessRequestEventArgs args) 0x42022ff0 + 0x0021f in filename unknown:0
at MIG.Gateways.WebServiceGateway.OnPreProcessRequest (MIG.MigClientRequest request) 0x42022e70 + 0x000b0 in filename unknown :0
at MIG.Gateways.WebServiceGateway.Worker (System.Object state) <0x41fff630 + 0x013c5> in :0

It seams to be looking for a file it cant find. any idea what I am missing or how to fix it?



@Bounz I uninstalled HG and reinstalled it again. I installed EchoBridge again and the two options are showing now. All I need to do now is get it working. Thanks Bounz.


@IanR not sure but I have a version 1.2 installed. You may be having a problem with the Mono version you have installed.


IanR - edit the systemconfig.xml file and remove the reference to the hgechobridge interface…

install the new one and then post up the HG log.


It’s ok, 1.2 is a “version” written down in readme file while 1.0.21 - is a build number and it’s the latest build.

No, all files are there, the problem is that some variable has null value while it’s expected to have a reference to a real object. Please, try to perform actions, suggested by David.


Might be worth having a read of this GitHub. All is not equal in the Alexa device world it appears. Factors like what Alexa device you own, what generation it is and what country you purchased it in seems to make a difference on your rate of success getting it to work


I tried what @David suggest but ended up reinstalling HG and then HAbridge.
Here is the log file:


2019-01-13 21:17:30.9629 Info SSDP Discovery Packet detected.
2019-01-13 21:17:30.9629 Debug Sending SSDP setup information to
2019-01-13 21:17:31.9637 Info SSDP Discovery Packet detected.
2019-01-13 21:17:31.9637 Debug Sending SSDP setup information to
2019-01-13 21:17:32.9644 Info SSDP Discovery Packet detected.
2019-01-13 21:17:32.9644 Debug Sending SSDP setup information to
“2019-01-13 21:17:33.0217 Info WebServiceGateway HTTP GET 200 /api/HomeAutomation.HomeGenie/Config/Interfaces.List/ [OPEN]”
“2019-01-13 21:17:33.0225 Info WebServiceGateway HTTP GET 200 /api/HomeAutomation.HomeGenie/Config/Interfaces.List/ [CLOSED AFTER 0.001 seconds]”
“2019-01-13 21:17:33.5230 Info WebServiceGateway HTTP GET 200 /api/HomeAutomation.HomeGenie/Config/Interfaces.List/ [OPEN]”
“2019-01-13 21:17:33.5238 Info WebServiceGateway HTTP GET 200 /api/HomeAutomation.HomeGenie/Config/Interfaces.List/ [CLOSED AFTER 0.001 seconds]”
2019-01-13 21:17:33.9650 Info SSDP Discovery Packet detected.
2019-01-13 21:17:33.9652 Debug Sending SSDP setup information to

I cant even find the file Interfaces.List within the homegenie directory’s. to check it…

It looks to be resaving the request from Alexa.

I am using an Amazon Echo (2nd Gen) - Smart speaker with Alexa.



So what exactly have you got installed. Are you saying you have HG, EchoBridge and HA Bridge installed on the same unit.