X10 Security devices, HG, HA-Bridge, & RM Broadlink


looks like a port conflict.


Turns out it was not port conflict but maybe the HG loading too many images at once… flushing the sockets here: made HG load again.

So now that I am back, I imported your HA brdige program again, and knowing it adds 5 generic dimming modules, and these will correspond to HA-brdige device number, I added my ARM/DISARM keyfob AND IT WORKS! SENDS RF!

Tuicemen, THANK YOU AGAIN!! I am working on documenting my experiences here!


Tuicemen, it has been a bumpy ride, but last night my DS7000 security system armed by HG thru RM emulated RF keyfob command!!! And this morning it shut off at 6am, 6:01am, 6:02, and 6:03am using the range choice in timer settings!

Now I need to get back to work on documenting all this for other window’s user’s!



Glad you finally have HG doing what you want. :clap:
The Key really is doing baby steps, Trying to get everything working all at once is frustrating.
I’m confident your documentation will surely help others!:+1:


Is there a way to set Broadlink RM to static IP? It decided to change from …0.3 to …0.5 and thus my HA-bridge cannot find it so my automatic arm/disarm no longer works. Sure, I can edit HA-bridge code to now go to …0.5 but that is no long term solution.

Guess I can try using its name instead although it is messy and long; I figured out to PING its name I have to append a “.” on the end…


So until we can statically set Broadlink RM IP address, we are at risk of loosing HA-bridge/RM functionality…

To that end, I found by pinging that the RM device name, as opposed to IP address which can change, is as listed in IP scans of computer, except it needs a period appended to end to work.

So I went to HA-bridge devices and edited the broadlink code from:



{“id”:“Broadlink_RMPROPLUS-89-15-3d.-272a”,“name”:“RM 2 Pro Plus”,“type”:“272a”,“ipAddr”:“Broadlink_RMPROPLUS-89-15-3d.”,“macAddr”:“34:ea:34:89:15:3d”,“command”:“ircommand”,“data”:


I had this same issue with the Broadlink you can fix the issue by doing the following.

In your router find where you can reserve IPs based on a Mac address. enter the Broadlinks mac address and the IP you wish it to use, save then reboot your router.


Thanks. I saw your comment on this earlier in another post; I could not find such a table then nor now. Actiontetc GT784WN DSL modem is my DHCP server. My method of changing from IP to RM name seems to have worked for the arm/disarm module and modem reset switch, although my scheduler did not arm last night… will have to experiment yet again to see if that was a fluke or result of my IP->name change…


Some routers have a section for wi-fi specific rules.
Have you looked in this area it lets you allow specific wi-fi access to different devices.
I can’t remember if it lets you specify IPs
My router in the city has this but not the one here.




Thanks for reminding me of the Port forwarding site - that is great place!

Unfortunately that is not my model; mine is the plain WN. But they have the special verizon model listed for my WN model by mistake. Mine does not have this feature.


Have you tried calling tech support?
Do you have a link to the correct manual PDF?


I understand this router is distributed by different ISPs if yours was provided to you by your ISP it most likely has a custom interface and you’ll need to contact your ISP.


I bought mine on line - I did NOT take frontiers model. My model I is apparently dumbed down model. There is no mac/ip assign. Yes, I have manual, yes I have been in contact with mfgr - I am a contributor to their forum where the many shortcomings of this model are fought daily by people.

Anyway, I solved it by going to RM name instead of IP address so ok with that. Thanks.


That was to be my next suggestion but I wasn’t sure that would work from HA-Bridge.
It’s good to know that as I don’t believe my city router has the reserve option either.


If the device and router stay on then the ip address should not change - unless its not following the way dhcp works!


Power blips have messed the IPs which DHCP handled in the past in the city.
Recently it has been ISP outages as I’ve had the same IP for over 5 years but as late I’ve had 3 different ones.
However a router reset is usually required after a ISP outage.

At my off grid place it is only ISP outages that affect DHCP (unless I deliberately reset the router)
I actually have not had issues with DHCP in the past but with more and more IOT devices running I find I’m going to have to reserve more and more IPs.
I’ve not had to worry about this in the past, DHCP has been doing its job nicely.


We wish the modem would stay on but not an option for us. Frontier oversold their DSL here in the country by about 500%: it means when someone new wants to go online, someone presently online gets kicked off to give up their socket. Only way to get back on line is to wait it out - sometimes a couple hours - or immediately cycle power and become the new kid on the block and get back on. This happens 3-10 times per day. Frontier linemen openly tell us their company is ignoring the issue, will not add capacity or otherwise fix it. They are in the mode of collect all the money they can before dumping the service to some dummy willing to buy it from them. So our IPs will continually change daily if not set static


that’s irrelevant as the ip address you are targetting is an internal one - so the router should give the same ip address out to the client, if the router reboots and the client doesnt then the client should still negotiate to keep the same ip address…

Agreed your wan IP will change, but that shouldn’t stop you from doing a reservation on an internal ip.


Ah… there is the explanation: yes, I cycled power on the RM unit as it seemed to stop work… so when it came back alive it picked the different IP address from the pool.

And without a reserve preferential IP function in my modem/router, I cannot do reservation.