HG process dies after about a day or so on raspberry Pi


My installation was not that stable either. I did not get Mono or HG messages though. I basically got frustrated after the 10th installation attempt. The info I provided was as optimized as I could come up with at the time, but it wasn’t perfect.


Your information you supplied earlier in the thread was working perfectly up till recently.

The Mono developers seem to have made changes in such a way that you can no longer tie version 4.5 of Mono to your Mono download.

What we need to do now is to get HomeGenie running in a current version of Mono. Maybe stripping back all the unnecessary add ins in HomeGenie till we find the offender as suggested earlier could help.


I’ve got a issue raised on the github site for a minimal version so this might be a good starting point…

Personally I would like to see Zwave, UPNP, X10 etc all split out as seperate projects and Interfaces that you install should you require them - also makes refactoring of those easier as it doesnt mean a new HG build, but that is @Bounz’s call


Also interesting around the mono version - I will take a look at this as well as it will probably be stopping my test hardware with the machinon from working…

A longer term option would be to ditch mono in its entirety and use .net core - but thats not a quick task!


If HomeGenie finds itself tied to a legacy version of Mono I’m afraid that not many Linux users will persevere with it.


many linux users probably shudder at the thought of it running in mono anway - which is where the docker route will help!


typing mono --version shows this:
Mono JIT compiler version 4.6.2 (Debian
Copyright © 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: normal
SIGSEGV: normal
Notifications: epoll
Architecture: armel,vfp+hard
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: sgen
Interestingly I never specifically installed a mono version I just installed HG 1.1 beta r526 if I remember right.


Maybe in all the excitement of trying to get HomeGenie working :laughing: you’d forgotten that Mono is a requirement of v526 to get it running http://genielabs.github.io/HomeGenie/#/get_started

V526 and Mono 5.4 Complete were probably the most stable combination I’ve used to date. It sorted out SSL certificates which were constantly causing failures when using email notifications.


Mono is still an evolving software. Not ideal I’ll admit but it worked well enough with HomeGenie up to v526.

I’ve read mixed reviews about Docker. Have you tried out rkt. Works nicely with systemd I believe. Would this be an alternative for running HomeGenie I’m the Linux environment.

Again you’re the expert here on this one.


Nope! That states for optional packages SSL to be specific.
the latest Debian Stretch (Full) comes with SSL, not sure about the lite version.
Also if I did install mono it would have been 5.4 or newer I would have thought.
I know I installed mono complete on my pi zero originally but with trying different versions of Debian I doubt I installed it separately last time.
Since that is running in the city I can’t check it right now.


The quote under that section you mentioned as follows

Note HomeGenie requires mono runtime version 3.2 or later.

As far as I’m aware it never came prepackaged with HomeGenie so I’m not sure how you came to have it without installing it manually.

Unless you use the separate key signing method of installing Mono from its own project, the standard version of HomeGenie in the Stretch repos is 4.x


I guess to be sure I’ll have to pull out a fresh SD card and attempt a install of Debian then HG.
I believe that’s all I did last time but getting old sucks, sometimes I forget what I walked into a room for.:frowning_face:


Yes, the best approach I found was Debian Stretch Lite and Mono Complete.

The big problem I found in the last few days was trying to tie Mono 5.4 to HGv526 though. You may have better luck than me.

Luckily I kept a base Debian image with Mono 5.4 tied to it so it’s a workaround for the moment. Saves downloading each time. Not ideal but it will do for the moment.


docker is the way forward for most people as it will also be xplat.


Just installed HG 1.1 Beta r526 on a new debian stretch it does install mono 4.6.2.


They may have changed the packing dependencies at a later stage. I always installed Mono manually. Version 4.x of Mono is not ideal either.

V.526 of HomeGenie has had no real development work carried out on it in nearly two years but if it’s just X10 that you’re using I don’t really see that being a problem for you.

Maybe you could install @bounz latest release and help him test it if you haven’t already done so.


Yes my setup is very minimal, X10 and HA-Bridge handles the other protocol sends.
I plan to install @Bounz latest as soon as I get some extra time.
I didn’t notice it till after I had reinstalled V.526.or I would have attempted it on the zero.