Having x10 remote actually work for a while

I ordered a new one should be here on Monday. Maybe this one will work better.

N9SWH General Class

[quote=“pjanits, post:40, topic:455”]
v26 it updated to. Half of 52. Reverse dyslexia.[/quote]
I do that all the time.
If I remember 23 and 26 was bad firmware for X10RF I’m at v20028
24 was good as that’s what I had to request. I don’t remember how the others were as sometime my device skipped a version update.

I’ll keep that in mind, thanks

Quick update,

Received a new RM pro+ Yesterday. It came with version 43. Tried to update it to v 20028 , it said it updated but didn’t. Still said v43. It would not read x10RF. and was shakey reading IR also. Pretty much worse than the first one. Today I sat down to try to figure this thing out with full concentration and … It was dead! ( plugged in all night - infant mortality) Would not power up. Power supply ok cable ok ( worked on my phone) but nothing from RM pro+ No lights no reset no nothing. I’m sending it back for another one ( yeah I know, I’m stubborn and a glutton for punishment). My wife says the third time is the charm. Ha.

N9SWH General Class

Recieved another new RM pro + yesterday. This one is also V43 it has no way to update, no advanced area to put a url in. It also will not see X10 rf. I downloaded some of other peoples X10 files including both of Tuicemen’s . When the buttons are activated the RM pro blinks it’s little orange light in front but no rf comes out. I used the AHP to watch any activity.
I have come to the conclusion that Broadlink has killed this ability in all new Units. I can load it up with all kinds of IR but no RF. Support is non existent. My email was answered with several url links for specific problems, none of which have anything to do with my problem. I tried a few of them but have received no reply at all.
I guess I will return this one also and go back to square one. They may get their act together one day but I don’t think I want to wait for it.

What frequency are you working with. 310mhz or 433mhz US or EU.

It’s funny because it scans and asks if you want to add it, but does not add. It sees something. If I put in someone else’s codes it acts like it sends but nothing comes out. Very frustrating, this is my third one.

Is it an EU or US model

It’s a US model. I think broadlink has crippled all the newer ones.

Unofficially it’s a hackers tool so I’m not really surprised. It happened to the EU model too.

Try searching for an older working firmware on the web which you can flash onto the unit. You might have to dig a little to find one.

Just to be clear I dug out my SDR Receiver it shows my x10 stuff at 310 Mhz. and the preset buttons on the RM pro from others files that blink the light like it’s working No output on any frequency.

N9SWH General Class

IAlthough this references the EU version it’s worth reading. http://www.paulhibbert.co.uk/2017/11/24/a-complete-guide-to-connecting-the-broadlink-rm-pro-and-broadlink-blackbean-to-alexa/

You’ll need to obtain an older firmware that corresponds to your model number that doesn’t have the RF issues.

If you don’t feel confident flashing a firmware onto the unit you may well have to return the unit for a refund rather than brick it.

There are other units out there that will do what you need. Wireshark is worth investigating too. Plenty of DIY Rf projects out there you could try too.

You might want to have a look at this. This may help you solve your problem or at least understand what’s going on https://github.com/lprhodes/homebridge-broadlink-rm/issues/222

Thanks for your input. Very informative. Apparently it’s crap and has been for quite a while now. Broadlink doesn’t seem to care. So I will return this one also.

Sounds like it. A Chinese knock off. Probably could make one yourself.