Amazon Alexa


#141

Hello
Can you active programmes eg “all on” or “all off” with HGbridge?
IanR


#142

I requested that feature when Dim support was added recently.


#143

Good evening everyone.
This morning I received the Amazon Echo Input.
I immediately connected it to the home audio system and the network and everything worked properly.
After the installation I started the dozens of tests to try to connect it to HG, without success.

In summary:

  1. Installed the HGEB interface and the HGX AmazonEcho program, with the link recommended by Bounz.
  2. Deactivated UPNP and any other service.
  3. Configured the Amazon Echo interface, inserting IP and HG port, and activated the AmazonEcho program.(The HGEB icon appeared at the top right (dark gray rather than light gray)).
  4. Configured the Main Group, inserting the Light Widgets testing1 / testing2 / testing3 (added by the AmazonEcho program) and giving them a name.

From this point I tried everything, but looking for new devices from the Alexa phone application, or asking to Alexa from Echo Input, no device is found.
Please could you kindly tell me the exact steps you need to pair the devices with Amazon Echo?
Roberto


#144

If the discovery icon is dark grey the Discovery service hasn’t started.

Once you have installed HGEB and disabled UPnP reboot the Pi before you enable HGEB.

Also make sure you have no username or password configured in HG. If you do just clear them in Settings. Ensure IPAddress and Port in HGEB match the ones you use in HG.


#145

@Pretediscrete,
Thank you for your quick reply.
I’m doing what you have indicated, I will inform you as soon as possible on the result.

P.S.I have no password set to HG, but in reference to the default user name “Admin”, I do not know how to remove it …

Thanks Again
Roberto


#146

@Pretediscrete,
as you suggested I made sure that the password was not present in settings, I also clicked on the “Disable” button, under the button for configuring the password. (I thought that in this way, even the user name “Admin”, which is proposed following the password setting request, is deactivated).

I deactivated the AmazonEcho interface, restarted the RPI and once restarted I made sure that HG’s IP and port remained the same as the HGEB Interface.

At this point I started the HGEB interface, but the icon at the top right continues to be dark gray.
Please, could you suggest me some solution to try to solve the problem?


#147

Ok just set a password for Admin. As soon as you have done that in Settings select Clear. That should clear username and password.


#148

Once you have the username and password clear, restart the Pi. Once it has rebooted you’ll need to enable HGEB to let the Discovery service start.

You can run HG in debug mode so when you enable the HGEB you can see exactly what the Discovery is doing.

To do this type the following in the Terminal

cd /usr/local/bin/homegenie
sudo mono HomeGenie.exe


#149

Roberto,

If you provide HomeGenie’s log files from your Pi it will greatly help in the investigation of what happens.

Usually, when an interface icon is a dark gray color it means that something went wrong during the interface startup process.


#150

@Petediscrete
Thank you for your suggestion. I tried to re-run your instructions and run sudo mono HomeGenie.exe and then activate HGEB, but nothing happens.

@Bounz, I’m trying to extract the Log file but I’ve always had a hard time doing it. By activating “Log File” and “Event Log”, clicking on “Download Today Log” the cvs file is empty, while clicking on the Blue icon in the upper right corner, after a short time the page freezes, but the only events that recurring every few seconds are those related to the tempering sensor (which I have never been able to set up to update every few minutes) …and MeterWatt …
As soon as I can extract the Log file I will send it …


#151

I do not know how, but following other forum discussions I managed to download this part of Log from terminal …
Among other things it would seem that the user name “Admin” was not removed via the settings screen, by deactivating the password option …

Homegenie Log.txt (6,1 KB)


#152

What information did you get about HGEB by running sudo mono HomeGenie.exe when you enabled it.


#153

Until now nothing … But I tried again by restarting the AmazonEcho program after entering the command sudo mono HomeGenie.exe, and this is the message that is continually presented:

logs
2019-02-07 14:34:35.0870 Info HomeAutomation.HomeGenie  0       HTTP binding failed.    SystemInfo.HttpAddress  +:8090

2019-02-07 14:45:39.4652 Debug Adding Gateway WebServiceGateway
2019-02-07 14:45:39.4735 Debug Setting Gateway options
2019-02-07 14:45:39.4779 Debug WebServiceGateway: BaseUrl=/hg/html
2019-02-07 14:45:39.4846 Debug WebServiceGateway: HomePath=html
2019-02-07 14:45:39.4846 Debug WebServiceGateway: Host=+
2019-02-07 14:45:39.4846 Debug WebServiceGateway: Port=8090
2019-02-07 14:45:39.4858 Debug WebServiceGateway: Username=admin
2019-02-07 14:45:39.4858 Debug WebServiceGateway: Password=
2019-02-07 14:45:39.4858 Debug WebServiceGateway: HttpCacheIgnore.1=^.*\/pages\/control\/widgets\/.*\.(js|html)$
2019-02-07 14:45:39.4890 Debug WebServiceGateway: HttpCacheIgnore.2=^.*\/html\/index.html
2019-02-07 14:45:39.4890 Debug WebServiceGateway: UrlAlias.1=api/HomeAutomation.HomeGenie/Logging/RealTime.EventStream:events
2019-02-07 14:45:39.4907 Debug WebServiceGateway: UrlAlias.2=hg/html/pages/control/widgets/homegenie/generic/images/socket_on.png:hg/html/pages/control/widgets/homegenie/generic/images/switch_on.pn                                        g
2019-02-07 14:45:39.4907 Debug WebServiceGateway: UrlAlias.3=hg/html/pages/control/widgets/homegenie/generic/images/socket_off.png:hg/html/pages/control/widgets/homegenie/generic/images/switch_off.                                        png
2019-02-07 14:45:39.4917 Debug WebServiceGateway: UrlAlias.4=hg/html/pages/control/widgets/homegenie/generic/images/siren.png:hg/html/pages/control/widgets/homegenie/generic/images/siren_on.png
2019-02-07 14:45:39.4917 Debug WebServiceGateway: EnableFileCaching=true
2019-02-07 14:45:39.5358 Debug Adding Interface Protocols.UPnP
2019-02-07 14:45:39.5421 Debug Setting Interface options
2019-02-07 14:45:39.5969 Debug Adding Interface HomeAutomation.ZWave
2019-02-07 14:45:39.6102 Debug Setting Interface options
2019-02-07 14:45:39.6170 Trace HomeAutomation.ZWave: Port=
2019-02-07 14:45:39.6747 Debug Adding Interface HomeAutomation.X10
2019-02-07 14:45:39.6773 Debug Setting Interface options
2019-02-07 14:45:39.7087 Trace HomeAutomation.X10: Port=
2019-02-07 14:45:39.7102 Trace HomeAutomation.X10: HouseCodes=A
2019-02-07 14:45:39.7149 Debug Adding Interface Protocols.MqttBrokerService
2019-02-07 14:45:39.7175 Debug Setting Interface options
2019-02-07 14:45:39.7328 Debug Adding Interface HomeAutomation.EchoBridge
2019-02-07 14:45:39.7354 Debug Setting Interface options
2019-02-07 14:45:39.7367 Trace HomeAutomation.EchoBridge: IPAddress=192.168.1.30
2019-02-07 14:45:39.7385 Trace HomeAutomation.EchoBridge: Port=8090
2019-02-07 14:45:41.9807 Info HomeAutomation.HomeGenie.Automation       6       Automation Program      Program.Status  Added
2019-02-07 14:45:42.0072 Info HomeAutomation.HomeGenie.Automation       7       Automation Program      Program.Status  Added
2019-02-07 14:45:42.0113 Info HomeAutomation.HomeGenie.Automation       16      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0162 Info HomeAutomation.HomeGenie.Automation       26      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0192 Info HomeAutomation.HomeGenie.Automation       34      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0280 Info HomeAutomation.HomeGenie.Automation       73      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0325 Info HomeAutomation.HomeGenie.Automation       74      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0373 Info HomeAutomation.HomeGenie.Automation       75      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0399 Info HomeAutomation.HomeGenie.Automation       82      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0432 Info HomeAutomation.HomeGenie.Automation       84      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0551 Info HomeAutomation.HomeGenie.Automation       88      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0579 Info HomeAutomation.HomeGenie.Automation       90      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0604 Info HomeAutomation.HomeGenie.Automation       91      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0630 Info HomeAutomation.HomeGenie.Automation       112     Automation Program      Program.Status  Added
2019-02-07 14:45:42.0747 Info HomeAutomation.HomeGenie.Automation       142     Automation Program      Program.Status  Added
2019-02-07 14:45:42.0848 Info HomeAutomation.HomeGenie.Automation       180     Automation Program      Program.Status  Added
2019-02-07 14:45:42.0848 Error HomeAutomation.HomeGenie Service.Utility.RunAsyncTask    Object reference not set to an instance of an object    Exception.StackTrace      at HomeGenie.Automation.Pro                                        gramManager.RoutePropertyBeforeChangeEvent (System.Object eventData) [0x00000] in <filename unknown>:0
  at HomeGenie.Automation.ProgramManager.SignalPropertyChange (System.Object sender, HomeGenie.Data.Module module, MIG.MigEvent eventData) [0x00000] in <filename unknown>:0
  at HomeGenie.Service.HomeGenieService+<migService_InterfacePropertyChanged>c__AnonStorey4.<>m__1 () [0x00000] in <filename unknown>:0
  at HomeGenie.Service.Utility+<RunAsyncTask>c__AnonStorey4.<>m__0 () [0x00000] in <filename unknown>:0
2019-02-07 14:45:42.0903 Info HomeAutomation.HomeGenie.Automation       200     Automation Program      Program.Status  Added
2019-02-07 14:45:42.0948 Info HomeAutomation.HomeGenie.Automation       81      Automation Program      Program.Status  Added
2019-02-07 14:45:42.0995 Info HomeAutomation.HomeGenie.Automation       93      Automation Program      Program.Status  Added
2019-02-07 14:45:42.1042 Info HomeAutomation.HomeGenie.Automation       76      Automation Program      Program.Status  Added
2019-02-07 14:45:42.1148 Info HomeAutomation.HomeGenie.Automation       145     Automation Program      Program.Status  Added
2019-02-07 14:45:42.1221 Info HomeAutomation.HomeGenie.Automation       77      Automation Program      Program.Status  Added
2019-02-07 14:45:42.1295 Info HomeAutomation.HomeGenie.Automation       8       Automation Program      Program.Status  Added
2019-02-07 14:45:42.1348 Info HomeAutomation.HomeGenie.Automation       78      Automation Program      Program.Status  Added
2019-02-07 14:45:42.1470 Info HomeAutomation.HomeGenie.Automation       505     Automation Program      Program.Status  Added
2019-02-07 14:45:42.1545 Info HomeAutomation.HomeGenie.Automation       29      Automation Program      Program.Status  Added
2019-02-07 14:45:42.6645 Info HomeAutomation.HomeGenie.Automation       1000    Automation Program      Program.Status  Added
2019-02-07 14:45:42.6711 Info HomeAutomation.HomeGenie.Automation       144     Automation Program      Program.Status  Added
2019-02-07 14:45:42.6755 Info HomeAutomation.HomeGenie.Automation       101002  Automation Program      Program.Status  Added
2019-02-07 14:45:42.6814 Info HomeAutomation.HomeGenie.Automation       1010    Automation Program      Program.Status  Added
2019-02-07 14:45:42.6906 Info HomeAutomation.HomeGenie.Automation       1017    Automation Program      Program.Status  Added
2019-02-07 14:45:42.6933 Info HomeAutomation.HomeGenie.Automation       100     Automation Program      Program.Status  Added
2019-02-07 14:45:42.7001 Info HomeAutomation.HomeGenie.Automation       154     Automation Program      Program.Status  Added
2019-02-07 14:45:42.7128 Info HomeAutomation.HomeGenie.Automation       1005    Automation Program      Program.Status  Added
2019-02-07 14:45:42.7159 Info HomeAutomation.HomeGenie.Automation       63      Automation Program      Program.Status  Added
2019-02-07 14:45:44.7773 Info HomeAutomation.HomeGenie.Automation       1007    Automation Program      Program.Status  Added
2019-02-07 14:45:44.7804 Info HomeAutomation.HomeGenie.Automation       1008    Automation Program      Program.Status  Added
2019-02-07 14:45:44.9496 Info HomeAutomation.HomeGenie.Automation       16      Automation Program      Program.Status  Idle
2019-02-07 14:45:44.9564 Info HomeAutomation.HomeGenie.Automation       34      Automation Program      Program.Status  Idle
2019-02-07 14:45:44.9682 Info HomeAutomation.HomeGenie.Automation       82      Automation Program      Program.Status  Idle
2019-02-07 14:45:44.9781 Info HomeAutomation.HomeGenie.Automation       84      Automation Program      Program.Status  Idle
2019-02-07 14:45:44.9838 Info HomeAutomation.HomeGenie.Automation       90      Automation Program      Program.Status  Idle
2019-02-07 14:45:45.0074 Info HomeAutomation.HomeGenie.Automation       91      Automation Program      Program.Status  Idle
2019-02-07 14:45:45.0138 Info HomeAutomation.HomeGenie.Automation       112     Automation Program      Program.Status  Idle
2019-02-07 14:45:45.0261 Info HomeAutomation.HomeGenie.Automation       84      Automation Program      Program.Status  Running
2019-02-07 14:45:45.0331 Info HomeAutomation.HomeGenie.Automation       16      Automation Program      Program.Status  Running
2019-02-07 14:45:45.0280 Info HomeAutomation.HomeGenie.Automation       82      Automation Program      Program.Status  Running
2019-02-07 14:45:45.0341 Info HomeAutomation.HomeGenie.Automation       142     Automation Program      Program.Status  Idle
2019-02-07 14:45:45.0384 Info HomeAutomation.HomeGenie.Automation       91      Automation Program      Program.Status  Running
2019-02-07 14:45:45.0396 Info HomeAutomation.HomeGenie.Automation       34      Automation Program      Program.Status  Setup
2019-02-07 14:45:45.0527 Info HomeAutomation.HomeGenie.Automation       112     Automation Program      Program.Status  Running
2019-02-07 14:45:45.0671 Info HomeAutomation.HomeGenie.Automation       82      Automation Program      Program.Status  Background
2019-02-07 14:45:45.0816 Info HomeAutomation.HomeGenie.Automation       16      Automation Program      Program.Status  Background
2019-02-07 14:45:45.0848 Info HomeAutomation.HomeGenie.Automation       91      Automation Program      Program.Status  Background
2019-02-07 14:45:45.0685 Info HomeAutomation.HomeGenie.Automation       180     Automation Program      Program.Status  Idle
2019-02-07 14:45:45.0874 Info HomeAutomation.HomeGenie.Automation       84      Automation Program      Program.Status  Background
2019-02-07 14:45:45.0996 Info HomeAutomation.HomeGenie.Automation       505     Automation Program      Program.Status  Idle
2019-02-07 14:45:45.1066 Info HomeAutomation.HomeGenie.Automation       112     Automation Program      Program.Status  Background
2019-02-07 14:45:45.1066 Info HomeAutomation.HomeGenie.Automation       29      Automation Program      Program.Status  Idle
2019-02-07 14:45:45.1279 Info HomeAutomation.HomeGenie.Automation       1000    Automation Program      Program.Status  Idle
2019-02-07 14:45:45.1395 Info HomeAutomation.HomeGenie.Automation       101002  Automation Program      Program.Status  Idle
2019-02-07 14:45:45.1442 Debug Event propagation halted - parameter manipulated by automation program 'Query on Wake Up' (91) (Name=Program.Status, OldValue=Running, NewValue=Background)
2019-02-07 14:45:45.1706 Info HomeAutomation.HomeGenie.Automation       1010    Automation Program      Program.Status  Idle
2019-02-07 14:45:45.1793 Info HomeAutomation.HomeGenie.Automation       90      Automation Program      Program.Status  Running
2019-02-07 14:45:45.1841 Info HomeAutomation.HomeGenie.Automation       100     Automation Program      Program.Status  Idle
2019-02-07 14:45:45.1908 Info HomeAutomation.HomeGenie.Automation       142     Automation Program      Program.Status  Running
2019-02-07 14:45:45.1941 Info HomeAutomation.HomeGenie.Automation       505     Automation Program      Program.Status  Running
2019-02-07 14:45:45.1970 Info HomeAutomation.HomeGenie.Automation       180     Automation Program      Program.Status  Setup
2019-02-07 14:45:45.2003 Info HomeAutomation.HomeGenie.Automation       29      Automation Program      Program.Status  Running
2019-02-07 14:45:45.2047 Info HomeAutomation.HomeGenie.Automation       90      Security System HomeGenie.SecurityArmed Disarmed
2019-02-07 14:45:45.2490 Info HomeAutomation.HomeGenie.Automation       63      Automation Program      Program.Status  Idle
2019-02-07 14:45:45.2787 Info HomeAutomation.HomeGenie.Automation       1007    Automation Program      Program.Status  Idle
2019-02-07 14:45:45.2787 Info HomeAutomation.HomeGenie.Automation       505     Automation Program      Program.Status  Background
2019-02-07 14:45:45.3199 Info HomeAutomation.HomeGenie.Automation       1008    Automation Program      Program.Status  Idle
2019-02-07 14:45:45.3591 Debug Starting Gateway WebServiceGateway
2019-02-07 14:45:45.4356 Info HomeAutomation.HomeGenie.Automation       180     Automation Program      Program.Status  Idle
2019-02-07 14:45:45.4408 Info HomeAutomation.HomeGenie.Automation       1010    Automation Program      Program.Status  Setup
2019-02-07 14:45:45.4443 Info HomeAutomation.HomeGenie.Automation       1008    Automation Program      Program.Status  Setup
2019-02-07 14:45:45.5232 Info HomeAutomation.HomeGenie.Automation       29      Automation Program      Program.Status  Background
2019-02-07 14:45:45.5626 Info HomeAutomation.HomeGenie.Automation       1000    Automation Program      Program.Status  Running
2019-02-07 14:45:45.7371 Info HomeAutomation.HomeGenie.Automation       1010    Automation Program      Program.Status  Idle
2019-02-07 14:45:45.7421 Info HomeAutomation.HomeGenie.Automation       100     Automation Program      Program.Status  Running
2019-02-07 14:45:45.7466 Info HomeAutomation.HomeGenie.Automation       34      Automation Program      Program.Status  Idle
2019-02-07 14:45:45.7520 Info HomeAutomation.HomeGenie.Automation       34      Automation Program      Program.Status  Running
2019-02-07 14:45:45.7533 Debug Event propagation halted - parameter manipulated by automation program 'Turn Off Delay' (112) (Name=Program.Status, OldValue=Idle, NewValue=Running)
2019-02-07 14:45:45.7586 Info HomeAutomation.HomeGenie.Automation       1008    Automation Program      Program.Status  Idle
2019-02-07 14:45:45.7648 Info HomeAutomation.HomeGenie.Automation       101002  Automation Program      Program.Status  Setup
2019-02-07 14:45:45.7795 Info HomeAutomation.HomeGenie.Automation       1008    Automation Program      Program.Status  Running
2019-02-07 14:45:45.8511 Info HomeAutomation.HomeGenie.Automation       1008    Automation Program      Program.Status  Background
2019-02-07 14:45:45.9056 Error System.Net.Sockets.SocketException: Address already in use
  at System.Net.Sockets.Socket.Bind (System.Net.EndPoint local_end) [0x00000] in <filename unknown>:0
  at System.Net.EndPointListener..ctor (System.Net.IPAddress addr, Int32 port, Boolean secure) [0x00000] in <filename unknown>:0
  at System.Net.EndPointManager.GetEPListener (System.String host, Int32 port, System.Net.HttpListener listener, Boolean secure) [0x00000] in <filename unknown>:0
  at System.Net.EndPointManager.AddPrefixInternal (System.String p, System.Net.HttpListener listener) [0x00000] in <filename unknown>:0
  at System.Net.EndPointManager.AddListener (System.Net.HttpListener listener) [0x00000] in <filename unknown>:0
2019-02-07 14:45:45.9109 Info HomeAutomation.HomeGenie.Automation       101002  Automation Program      Program.Status  Idle
2019-02-07 14:45:45.9184 Info HomeAutomation.HomeGenie.Automation       63      Automation Program      Program.Status  Running
2019-02-07 14:45:45.9252 Warn Error starting Gateway WebServiceGateway
2019-02-07 14:45:45.9346 Debug Disabling Interface Protocols.UPnP
2019-02-07 14:45:45.9514 Info HomeAutomation.HomeGenie.Automation       101002  Automation Program      Program.Status  Running
2019-02-07 14:45:45.9545 Debug Disabling Interface HomeAutomation.ZWave
2019-02-07 14:45:45.9769 Debug Disabling Interface HomeAutomation.X10
2019-02-07 14:45:45.9991 Debug Disabling Interface Protocols.MqttBrokerService
2019-02-07 14:45:46.0509 Info HomeAutomation.HomeGenie.Automation       101002  Automation Program      Program.Status  Background
2019-02-07 14:45:46.0643 Debug Enabling Interface HomeAutomation.EchoBridge
2019-02-07 14:45:46.1028 Info Starting HGEchoBrige Version 1.0.22.0
2019-02-07 14:45:46.2234 Info Mig: Connecting to Homegenie API [192.168.1.30:8090] to discover valid devices
2019-02-07 14:45:46.2238 Info Log: Connecting to Homegenie API [192.168.1.30:8090] to discover valid devices
2019-02-07 14:45:46.3775 Error System.IO.FileNotFoundException: Could not load file or assembly 'System.Net.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its de                                        pendencies.
File name: 'System.Net.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
  at MIG.Interfaces.HomeAutomation.EchoBridge.Connect () [0x00000] in <filename unknown>:0
  at MIG.MigService.EnableInterface (System.String domain) [0x00000] in <filename unknown>:0
  at MIG.MigService.StartService () [0x00000] in <filename unknown>:0

#154

As a test what I suggest you could do is do a fresh install of HG on a separate SD card. Don’t restore your HG back onto this. Create a few devices then follow the instructions for installing the HGEB to see if you can get the discovery service working first. From there we can see what is causing you problem.

Could you tell us what version of HG you are using and what version of Raspbian and Mono is running on your system.


#155

On this raspberry (RPI 2) are installed:
HG 1.1betaR526
Raspbian Id=7 Wheezy
Mono Version 3.2.8 (Debian 3.2.8+dfsg-4+rpi1)
Perhaps it could be caused by the mono version?

Before doing a new installation I could try another RPI 3 on which it is installed:
HG 1.1StableR527
Raspbian Id=9 Stretch
Mono Version 4.6.2 (Debian 4.6.2.7 +dfsg-1)


#156

I just tried with RPI 3, the result is the same.
The HGEB icon at the top right is light gray even in this case …


#157

Following errors reported on RPI3 log:

2019-02-07 17:41:32.8177 Error HomeAutomation.HomeGenie Service.Utility.RunAsyncTask Object reference not set to an instance of an object Exception.StackTrace at HomeGenie.Automation.ProgramManager.RoutePropertyBeforeChangeEvent (System.Object eventData) [0x0003c] in <2250731ad6eb446a85c127763784f49f>:0
at HomeGenie.Automation.ProgramManager.SignalPropertyChange (System.Object sender, HomeGenie.Data.Module module, MIG.MigEvent eventData) [0x0002b] in <2250731ad6eb446a85c127763784f49f>:0
at HomeGenie.Service.HomeGenieService+<migService_InterfacePropertyChanged>c__AnonStorey4.<>m__1 () [0x00001] in <2250731ad6eb446a85c127763784f49f>:0
at HomeGenie.Service.Utility+c__AnonStorey4.<>m__0 () [0x00002] in <2250731ad6eb446a85c127763784f49f>:0
2019-02-07 17:41:39.5957 Error System.Net.Sockets.SocketException (0x80004005): Address already in use
at System.Net.Sockets.Socket.Bind (System.Net.EndPoint localEP) [0x0004c] in :0
at System.Net.EndPointListener…ctor (System.Net.HttpListener listener, System.Net.IPAddress addr, System.Int32 port, System.Boolean secure) [0x0004a] in :0
at System.Net.EndPointManager.GetEPListener (System.String host, System.Int32 port, System.Net.HttpListener listener, System.Boolean secure) [0x000be] in :0
at System.Net.EndPointManager.AddPrefixInternal (System.String p, System.Net.HttpListener listener) [0x00064] in :0
at System.Net.EndPointManager.AddListener (System.Net.HttpListener listener) [0x00030] in :0
2019-02-07 17:41:39.6067 Warn Error starting Gateway WebServiceGateway
2019-02-07 17:41:39.6102 Debug Disabling Interface Protocols.UPnP
2019-02-07 17:41:39.6165 Debug Disabling Interface HomeAutomation.ZWave
2019-02-07 17:41:39.6308 Debug Disabling Interface HomeAutomation.X10
2019-02-07 17:41:39.6527 Debug Enabling Interface HomeAutomation.EchoBridge
2019-02-07 17:41:39.6658 Info Starting HGEchoBrige Version 1.0.21.0
2019-02-07 17:41:39.7096 Info Mig: Connecting to Homegenie API [192.168.1.31:8099] to discover valid devices
2019-02-07 17:41:39.7096 Info Log: Connecting to Homegenie API [192.168.1.31:8099] to discover valid devices
2019-02-07 17:41:39.7135 Error System.TypeLoadException: Could not load type ‘MIG.Interfaces.HomeAutomation.Api.HgApiHelper’ from assembly ‘MIG-EchoBridge, Version=1.0.21.0, Culture=neutral, PublicKeyToken=null’.
at MIG.Interfaces.HomeAutomation.EchoBridge.Connect () [0x0008c] in :0
at MIG.MigService.EnableInterface (System.String domain) [0x00039] in <23027418f9174dd68010f21fc4a3aea3>:0
at MIG.MigService.StartService () [0x00097] in <23027418f9174dd68010f21fc4a3aea3>:0


#158

To be honest Wheezy is three releases behind Stretch which I’m using.

I really do advise you install Stretch Lite which in turn will give you Mono 4.6. From there you can install whichever version of HG you like and then you can restore your HG backup.

This should resolve your difficulties with HGEB. Once you’ve done that report back and let us know your results.


#159

Petediscrete, thank you for your answers.
I would try to make a new installation of HG on a new board without any problem.
I have only some doubt that this will solve the problem for the reason that I have the same problem also on the last test done on RPI3, on which I made a new installation only a short time ago, without having installed almost anything.
I will keep you updated as soon as I will find more time to test with a new installation.
Thank you again,
Roberto


#160

You really should also update to a newer HG version. Either @Bounz latest or Gene’s latest build.